Jump to content
Classifieds is broken, please do not submit any new ads ×

Twsbi Mini Problem With O-Ring: Help!



Oldtimer

Recommended Posts

I had cleaned my TWSBI mini but when the water was clear after a few flushings, I still saw some black specs and threads hanging from the piston. So I disassembled it completely and made sure everything was out. The piston looked good, perfect.

 

On the next water flushing after assembling there was still some of this debris. I removed the nib and the section and looked into the empty barrel from the side of the nib and found this. The small o-ring is dissolving, kaput. The ink was Black Swan in Australian Roses. Since the nib is EF I guess I think it was too long on the barrel? Was it another of the previous inks that did it? I will never know, but the area where it is right now makes it impossible to be replaced by me.

 

I suppose I can send it back to have this o-ring replaced... Just wanted to know who else has exhibited this kind of defect.

 

I will get better photos, but surely, I think I have to return to TWSBI.

post-114244-0-53229400-1488235707_thumb.jpg

post-114244-0-14749200-1488235737_thumb.jpg

post-114244-0-70199700-1488235840_thumb.jpg

Edited by Berelleza
Link to post
Share on other sites
  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

  • Oldtimer

    4

  • alc3261

    1

  • Jamerelbe

    1

  • Fit_to_Print

    1

Top Posters In This Topic

Posted Images

That ring cannot be placed in its location without special tools. It is inside the barrel where you attach the section, not on the outside... Not regular size, very small. I have regular size o-rings that would be appropriate for the outside of the barrel.

Edited by Berelleza
Link to post
Share on other sites

That ring cannot be placed in its location without special tools. It is inside the barrel where you attach the section, not on the outside... Not regular size, very small. I have regular size o-rings that would be appropriate for the outside of the barrel.

Any address / information or site I can contact TWSBI Customer Service?

Link to post
Share on other sites
  • 3 weeks later...
Fit_to_Print

I think the "o-Ring" was dry ink, stain. See pic included.

I have an Eco and a couple 580s that have each seen plenty of Australian Roses (I admire your taste), with no problems.

 

Have you tried digging in there with a q-tip? It's hard to tell where exactly the issue is from the pics. I hate to give too much advice because I haven't used a mini.

"Never be a spectator to unfairness or stupidity" (Christopher Hitchens)

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now







×
×
  • Create New...