Jump to content
Classifieds is broken, please do not submit any new ads ×

Help! Need To Disassemble A Stuck Skyline Cap


Recommended Posts

Hi folks,


I'm trying to restore a green moire Eversharp Skyline pen. The problem is that the cap doesn't screw securely onto the barrel. I've tried screwing the cap on to several other Skyline barrel-section assemblies, and it screws on fine. I've also tried screwing the cap onto its own barrel without the section and it screws on fine. It only doesn't screw on fine to this particular barrel with a section installed.


So, I believe I need to take apart the cap and shorten the length of inner cap. Ordinarily, Skyline caps are dead-simple to take apart. This one, however, is proving a Right Little (bleep).


I've tried unscrewing it as I do normally with Skylines. Failed. I soaked it in an ammonia-water ultrasound bath. Failed. I've heated it with my heat gun. Failed. I've tried ultrasounding it in the bath for ten minutes and then heat-gunning it, and failed.


I'd be grateful for any suggestions. Other than the cap not screwing on, it's a lovely pen.





Link to comment
Share on other sites

  • Replies 1
  • Created
  • Last Reply

Top Posters In This Topic

  • rtrinkner


Popular Days

Top Posters In This Topic

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...